Skip to:
Content
Pages
Categories
Search
Top
Bottom

BBPress doesnt show people a topics last reply? Need help fast!

  • My users are complaining already! When a user has posted a new reply in a topic. I can no longer see it when clicking on it.

    I have to look at the stats next to the topicname, where it says “28 posts +3 more” and click on “3 more” to see them. Why is this? Normal users can’t click on “+3 more”. Is this some sort of protection the database overloading?

    I’ve made no changes to settings at all.

    -

    Have a look yourself.

    Go to http://www.michaeljackson.no/forum and see the post “Når ble du Michael Jackson fan?”. It says Bettabet93 was the last to answer, but when clicking on the topic, you don’t see her answer.

    -

    It seems when this occurs in a topic, more replies will eventually allow users to see the unseen replies made before.

Viewing 20 replies - 1 through 20 (of 20 total)

  • chrishajer
    Participant

    @chrishajer

    Sounds like the user is marked as a bozo or that the posts are marked as spam by Akismet. I would turn off the Akismet plugin first.

    You can see more than normal users as keymaster.

    I don’t use Akismet or Bozo plugin at all.

    Some topics just won’t show the last reply, until someone else posts more replies. Why does bbpress wait with showing this? Why are the last replies not visible instantly?

    I’m really pissed off right now. Is there any reason BBpress is starting to ruin everything for me all of the sudden?

    Now posts I’ve deleted becomes undeleted again, and then duplicated.

    And how come deleted posts aren’t really deleted? But instead just hidden?


    chrishajer
    Participant

    @chrishajer

    A decision was made to mark posts as deleted rather than delete them completely. Just a design decision. I prefer it this way; others want them gone forever.


    chrishajer
    Participant

    @chrishajer

    I was able to create an account, log in and make a new topic:

    http://www.michaeljackson.no/forum/topic.php?id=130

    I was able to add a reply to this topic as well:

    http://www.michaeljackson.no/forum/topic.php?id=6&page=8&replies=220#post-3577

    Someone posted soon after me, but for about 10 seconds I was listed as the last poster.

    So, it seems to be working well for me. Is it not working for everyone?

    chrishajer, the strange thing is it doesn’t always happen. But sometimes the last poster won’t be seen until much much later. I’ve crosschecked this with several users. I don’t know what the criteria is for this bug to occur.

    In the thread “Post bilde av deg selv” – today I had to redelete all deleted posts, which was about 20 posts. These were duplicates of the previously deleted posts. Why did this only happen in one topic?

    I’ve deleted alot of spambots lately, but they’ve done no harm at all, other than registering.

    I’ve also installed the plugin Mass Delete Users, but these bugs doesn’t seem to have anything to do with that, and they did not start to occur imediatly after installing the plugin either.

    It’s gonna be hard to tell you the next time this bug happens, maybe I can add you to msn and notifiy you the next time? As you see in my original post in this thread, thats the topic it happened to last time.

    I remember that i have this problem too on my bbPress 1.0.2 but no always.


    chrishajer
    Participant

    @chrishajer

    What if an incompatible plugin is creating problems for you? The problems you’re having are not normal. I noticed that the mass delete users plugin is good up to 0.9 only, but you posted there that it works with 1.0.2.

    http://bbpress.org/plugins/topic/mass-delete-users/

    How about preventing the spambot registrations with the Human Test plugin instead, and not trying to mass moderate users? Maybe it’s deleting some references to the users, but not all? Or there are stranded posts or something, and that throws off the numbering or something?

    hpguru, what plugins are you using?

    Marius-, what other plugins are you using?

    It doesn’t happen by default in an installation with very few plugins running, so it might be a problem with a plugin, or could be a problem with the server. Software sometimes acts weird when a partition or MySQL runs out of space or memory.

    chrishajer, I use the following plugins:

    Allow Images

    BBcode Buttons Toolbar

    BBcode Lite

    BBvideo

    Mass Delete Users

    Social It

    These are vital for me though, I got many users depending on these as core functions already. This problem did interestingly enough, occur after I had installed Mass Delete Users. Not imediatly though.

    Deleting users works, but maybe it does something else that I can not see – that fucks up something else?

    Do human test work for 1.02?


    chrishajer
    Participant

    @chrishajer

    I would stop using the Mass Delete Users plugin. I suspect it’s doing something that’s incompatible with 1.0 and something is going on with the users it deletes and the ones that are left behind. I would stop using that then do a recount in the admin. I’m not sure if recounting fixing user-related things that might have gotten borked.

    I don’t think Allow Images, either BBcode plugin, BBvideo or Social It would cause any problem like this. Unless the problem occurs on threads with (or without) images or threads with (or without) video.) The Social IT appears to be on every post.

    I’m not sure about Human Test for 1.0 – I don’t think I’ve ever tried it. I do have it working with a 1.0RC, I forget which version though. All you can do is try it. If it activates without error, that’s good. If you try to register and it prevents incorrect answers and allows correct answers, and the registration goes through, then it works.

    I don’t think disabling Mass Delete is going to make everything better right away. I have a feeling that it’s doing something to the user data in the database, and that will remain there even after you deactivate the plugin.

    The other possibility is something going on with the host. But if all the other software is running fine there, that’s probably not a problem.

    My plugins

    * Akismet

    * Human Test for bbPress

    * BB Anonymous Posting

    * Related Topics

    * bbVideo

    * Allow Images

    * BBcode Lite

    * BBcode Buttons Toolbar

    * bbPress Smilies

    * Topics Per Page


    chrishajer
    Participant

    @chrishajer

    If your issue is persistent hpguru, you should probably start a new topic. I know you were just adding to the voices who are having similar problems, and not even really looking for help, but if you do need help, please start a new topic.

    the bug has happened again!

    If you are quick to check my forum out now, you can see for yourself.

    Go to http://www.michaeljackson.no/forum and see the top discussion “Velkommen til nytt forum”. There are six pages, where I – Marius have the last reply. But when clicking on number “6″, you don’t see my last reply at all. You see user “eps” reply instead, mine is not showing at all, anywhere in the topic. It has not appeared yet.


    chrishajer
    Participant

    @chrishajer

    If you change the page 6 to a page 7 in the address bar, your post comes up. It looks like an issue with pagination. The front page and the topic page showed only 6 pages, but there were actually 7 pages and yours (and another, and now two others) were on page 7.

    So what plugins do you have that would affect pagination? Anything that would hide posts for any reason? Looks like bbPress is counting up enough posts to show that there are 6 pages, but there are really 7. I suspect the post count is wrong on the front page too (it said 180, but there were probably more like 180, assuming 30 per page.)

    What version of bbPress? And what plugins?

    I think you’re on to something Chrishajer! But I have already listed my plugins above, and none of them affects counting – that I know of.

    There must be some sort of bug in BBpress v. 1.02. Thats what I use.

    Cause how come this only happens occasionally, and not all the time. If you try to post there, you can see for yourself, that eventually, page 7 will appear. Try posting one or two times, and it will trigger the creations of Page 7.


    chrishajer
    Participant

    @chrishajer

    Have you tried a recount in the admin? Maybe there was something caught as spam or bozo, then rescued, and the count got messed up? Can you post the results of recounting here?


    chrishajer
    Participant

    @chrishajer

    My guess out of your list of plugins would be the mass delete users plugin. Maybe the post counts and pagination rely on the user being a valid user or something? I would disable that plugin and then do a recount and test.

    I’ve tried recounting and restocking everything. None of that helps

    Gonna try removing Mass Delete Users soon, just need some time. I get two new spambots a day now you see. It seems the more I delete them, the more they register.

    I just installed Human Test and can confirm it works with BBPress 1.02.

    I deactivated Mass Delete Users, so lets hope these spambots doesn’t know what 4+2 is.

Viewing 20 replies - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.