Skip to:
Content
Pages
Categories
Search
Top
Bottom

bbPress 2.2.2 released


  • John James Jacoby
    Keymaster

    @johnjamesjacoby

    2.2.2

    • RTL and i18n fixes
    • Improved user profile theme compatibility
    • Fixed incorrect link in credits page
    • Fixed admin area JS issues related to topic suggest
    • Fixed template part reference in extras user edit template

    Thanks everyone that’s been contributing feedback here in the forums and patches on trac!

Viewing 25 replies - 1 through 25 (of 27 total)

  • kannued
    Participant

    @kannued

    Awesome, let’s try a fresh conversion…..:( Still mostly Anonymous associated with the topics.


    Zubat2011
    Participant

    @zubat2011

    Hello I was using bbPress 2.1.2 and update to 2.2.2 but my theme seems to not like it or well the theme has a bbPress theme in it so I cant use 2.2.2 at this time and I don`t have a backup of 2.1.2 can you tell me where I can get a download of 2.1.2 pls help …..


    LabSecrets
    Participant

    @labsecrets

    Between 2.2.1 and 2.2.2, we found that the profile pages suddenly “vanished” (but the code was still there). It was a CSS issue.

    For our clients and personal sites, the fix was on line 78 of the default css:

    We changed “clear:none” to “clear:both”


    #bbpress-forums #bbp-user-wrapper ul.bbp-lead-topic, #bbpress-forums #bbp-user-wrapper ul.bbp-topics, #bbpress-forums #bbp-user-wrapper ul.bbp-forums, #bbpress-forums #bbp-user-wrapper ul.bbp-replies, #bbpress-forums #bbp-user-wrapper fieldset.bbp-form {   clear: both; }


    MickeyRoush
    Participant

    @mickeyroush

    I noticed in this update that the two CSS files:

    bbpress.css
    bbpress-rtl.css

    were updated but the min versions where not.

    I just YUI compressed them myself, to create a min version of each.


    technotip
    Participant

    @technotip

    How do I select my forum theme?
    No option present in the settings!


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    @technotip – If there’s only one theme, the option is hidden.


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    @mickeyroush – Annoying. Usually bumped automatically. Will fix. Thanks.


    OC2PS
    Participant

    @sooskriszta

    As reported elsewhere, my theme doesn’t seem to like bbPress 2.2.2 either.

    The problem caused is that I think the template files that make bbPress work with other themes broke.

    I can still go to the forum pages with direct URLs or links in forum list widget, but the forums (list of forums or list of topics) are not visible. All I see in content area is page/forum title and forum description.

    Similarly, on topic pages, I see topic title, but nothing else…

    When I view source, the code is not there. e.g. when on forums home I view code, I can’t find the forum names (except in the forum list widget)

    P.S. Reinstalling 2.2.2 has not resolved the issue.


    John James Jacoby
    Keymaster

    @johnjamesjacoby


    OC2PS
    Participant

    @sooskriszta

    @johnjamesjacoby That resolves the issue!


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    @sooskriszta – your theme is using query_posts() or is misbehaving in some other way. Maybe creating a WP_Query() that it’s resetting? Either way, I can remove that bit, but bbPress needs to take care to only intercept ‘the_content’ filters when it’s supposed to.


    sunflyer
    Participant

    @sunflyer

    on my installation I want to use the default theme, but it looks like its appearing with no style sheet attached. Also when I make a new topic its kind of “invisible” to the public and me. It says this forum has no posts or topics but it does! What could be wrong ?


    kraigg
    Participant

    @kraigg

    @johnjamesjacoby Thanks for all the time and effort you’ve put in to quickly release fixes and updates. It’s much appreciated.


    Annie S Spratt
    Participant

    @annie-s-spratt

    Evening! Just installed the update and now I am getting big fat 404′s on all my forums pages which are currently set to ‘Private’, the one forum that is set to ‘Open’ works fine however.

    Any ideas folks?


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    @annie-s-spratt – Link to your site?


    szerman
    Participant

    @szerman

    I updated bbPress and now only two forums out of six are listed on my forum page. The Continue Reading link is not working either, but I would prefer to have all my forums listed on the same page.

    See here – http://keyblogging.com/support/


    dwbroad
    Participant

    @dwbroad

    I’m having the same issues as Annie, 404s on forums unless they’re private. Was working fine with whichever version I updated from, 2.1.something

    Cheers,
    David


    silviorelli
    Participant

    @silviorelli

    I have the same issue of Annie S Spratt.
    My “Private” forum is gone, the forum index (www.my-domain.it/forums/forum/name-of-the-forum/) tells me “Sorry, no posts matched your criteria.”

    But topics are reachable via a direct link (making the forum public, taking the url of a topic and then making again the forum private)


    Phill
    Participant

    @sharkbites

    I’m having an issue I can’t seem to figure out. I’ve had bbpress forums on another one of my sites for awhile so when I decided to create a new site that was the first thing I installed – unfortunately I’m still stuck at this point. It’s a fresh wordpress 3.4.3 install with bbpress 2.2.2. For some reason the forums just don’t want to show up on my page (http://indiegamehut.com/forums). The theme was designed for Buddypress and BBpress.

    I also commented out lines 657 and 658 in the theme-compat.php file with no luck. Any suggestions?


    Milleogco.dk
    Participant

    @milleogcodk

    HELP ME – I updated – like other users – and my FORUM disappeared! What to do??

    Need my site to be running again SOOON!

    Mille;o)


    silviorelli
    Participant

    @silviorelli

    Take a look here: http://bbpress.org/forums/topic/roles-and-capabilities-in-bbpress-2-2/

    I fixed my disappeared forum using the forums role repair tool, located in: Admin > Tools > Forums


    dwbroad
    Participant

    @dwbroad

    Yes! Thanks @silviorelli! Tried everything to get Private forums to show, was about to revert to 2.1 but ran the repair on ‘Remap existing users to default forum roles’ and now it seems to work! Phew…

    Full details are explained in the link (http://bbpress.org/forums/topic/roles-and-capabilities-in-bbpress-2-2/)


    szerman
    Participant

    @szerman

    I have repaired all items in the tools section and still only two forums out of six are listed on my forum page. (http://keyblogging.com/support/). Please help!


    Milleogco.dk
    Participant

    @milleogcodk

    Still NO luck here either…. MY FORUM still doesnt work….I have tried all your ideas…
    Im going to deactivate – delete and start all over…. NOT positive thinking from me….


    anthonyluth09
    Participant

    @anthonyluth09

    @szerman It looks like your default forum slug is at /forums not support. Are you sure you have a page setup at /support?

Viewing 25 replies - 1 through 25 (of 27 total)

You must be logged in to reply to this topic.