Skip to:
Content
Pages
Categories
Search
Top
Bottom

bbPress 2.1 – Theme Compatibility


  • John James Jacoby
    Keymaster

    @johnjamesjacoby

    You posted, I listened.

    Version 2 of bbPress’s theme compatibility is now in the 2.1 plugin branch of code for your perusal. This second iteration removes the need to add current_theme_support() to your theme, and totally automates the process.

    If your child or parent theme contains the template files that bbPress looks for, bbPress will use them. If not, bbPress will fall back on it’s default templates and styling. No more logic necessary.

    Please test it. It’s new code with a new approach, so I’d like to get some fresh eyes on things right away to avoid a long beta period like 2.0 had.

    Cheers!

You must be logged in to reply to this topic.