Skip to:
Content
Pages
Categories
Search
Top
Bottom

bbPress 1.0-alpha-2 released

Viewing 17 replies - 26 through 42 (of 42 total)
  • With 1.0 alpha 2 I have found that the logins work independently for WordPress and bbPress when they have been integrated.

    So I can login into WordPress but also have to login to bbPress – the login isn’t remembered, and the same the other way aorund. When I login into bbPress, I have to then login into WordPress.

    But hey, at least the logins are being shared and this seems good enough for me to make the bbPress forums live.

    However there seems to be some partial login working between WordPress and bbPress as you will see as follows with respect to some analysis I did.

    I hope this is of some use to the team.

    LOGIN AS ADMIN:

    LOGIN ON WORDPRESS:

    Login OK and admin features OK on WordPress

    Not logged into bbPress (e.g. register link and login boxes appear)

    When trying to access /bbpress/bb-admin – redirected back to /bbpress

    Log out of WordPress and..

    LOGIN ON BBPRESS:

    Login OK and admin features OK on bbPress

    Not Logged into WordPress properly (e.g. comments section says login/register and no comments text area, register/login links appear in meta section)

    However, when trying to access /wordpress/wp-admin – appears as logged in as admin OK with all admin features in admin area only.

    LOGIN AS USER:

    LOGIN ON WORDPRESS:

    SAME AS FOR ADMIN:Login OK and admin features OK on WordPress

    SAME AS FOR ADMIN:Not logged into bbPress (e.g. register link and login boxes appear)

    When trying to access /bbpress/bb-admin – redirected back to /bbpress

    Log out of WordPress and..

    LOGIN ON BBPRESS:

    Login OK and profile features OK on bbPress

    Not logged into WordPress

    However, trying to access /wordpress/wp-admin – appears as logged in (obviously with no admin features).

    You guys are really doing a great job!

    I have found a problem with the login between WordPress and bbpress. Alpha 1 didn’t have this issue.

    It’s the same as @bharatk reported.

    I haven’t attempted this alpha 2 install yet, but I will sometime this weekend hopefully, however, in regards to the issue that bharatk was seeing in alpha 1… I was seeing the same thing. When integrating with WordPress 2.6.2, from the looks of it, you are only able to be logged in AND access the admin page of either WordPress or bbPress at one time. It seemed to work fine as a normal user to log into both entities at the same time and retain function, but I can double check that again before I upgrade. It just seems like the Admin functionality is limited to being logged in to either WordPress or bbPress at one time. If you log into one and then want to go to the other, you have to log out of the original one you logged in to. Let me know if you want any additional information before I upgrade and I can get it for you.

    I have WordPress 2.6.2 and bbPress 1.0 Aplha 2 running and integrated in my site (a .me domain). Logins from both WordPress and bbPress work. I have it set to only use the WordPress login just for consistency sake, but have tried logging in from both sides and once I am logged in to one side I am automatically logged in to the other. If I register using the WordPress registration, the user information carries over into the bbPress user details and likewise the other way around. Also if I login via bbPress and visit my user profile and update my bbPress user details, those same details are updated when I visit my WordPress profile!

    Seems to be working well! Nice job guys!!

    Cheers!

    Josh

    hey josh,

    can u tell how have u integrated both of them ?

    how did u manage to get their logins work together ?

    if you can show a demo it`ll be great

    Regards

    Also, Josh,

    Would please confirm that you followed the Dox to the letter/character!

    Were these brand new installs or did you add the forum to an existing WP install?

    Thanks.


    joshbruce
    Member

    @joshbruce

    hey guys, been incredibly busy the past several days. work, home and freelance design work has been crazy…will get back as soon as possible… – Josh -

    I’m using wordpress 2.6.3 and just upgraded my forum to 1.0-alpha-2 integration works perfectly by following the docs to the letter. The first time I upgraded I didn’t manage to make the integration work the main reason probably is because I just copied the bb-config.php from my old installation. This time I deleted it and do the install again, I put all my database information and just follow the prompts it will detect that bbpress is installed then proceed with the database upgrade. Just make sure that settings for your bb-config.php and wp-config.php are the same for AUTH_KEY, SECURE_AUTH_KEY, LOGGED_IN_KEY’ under the bbpress integration menu in the admin panel also make sure that the “auth” = “auth_salt”, “secure auth”=”secure_auth_salt”, and “logged in” =”logged_in_salt” in WordPress /wp-admin/options.php are the same.

    The only issue I found is that when i logged out in either bbpress or WordPress i’m still logged in on the other. Probably a cookie issue i’m not sure though, so I have to logged out manually from both.

    –Update: After additional testing I found out that when I logged in using WordPress I can only logged out completely using WordPress logged out meaning I am logged out both from bbpress and WordPress. Same with bbpress if I logged in using bbpress I can logged out completely by using bbpress logged out. If I use WordPress login I cannot logged out from bbpress by using bbpress logged out but can completely logged out if I use wordpress logged out. If I logged in using bpress, I can logged out in WordPress by using WordPress logged out but I’m stil logged in in bbpress so if I want to logged out completely I have to use bbpress to logged out completely.


    sc0ttbeardsley
    Member

    @sc0ttbeardsley

    I seem to be having the admin login problem as well. I checked the salt settings and they match. I think this is a problem with the login integration. When I login to wordpress first I can post comments to bbpress but that is about it. The bbpress logout button is broken and wordpress doesn’t seem to recognize bbpress-originated logins.

    It certainly is close though. I’ll dive into the code to see if I can’t figure it out.

    @sc0ttbeard: Hey Scott, take a look at a previous post of mine to hopefully jump-start your audit. I wonder if it’s a simple server config issue wrt cookie domain path… I’m going to RTFM.


    lostdeviant
    Member

    @lostdeviant

    I started a thread of several issues I’m having with Alpha-2. I hope they’ll be fixed in Alpha-3.


    jasonfrank77
    Member

    @jasonfrank77

    thanks guys for releas))


    sc0ttbeardsley
    Member

    @sc0ttbeardsley

    OK, I’ve looked at the other thread and looked at the cookie interaction on my site and have it working. I did have to make a change to my wordpress installation to get it to work. Here is what I did:

    My wordpress installation is at sacbikekitchen.org

    My bbpress installation is at sacbikekitchen.org/forum/

    I added the following to my /forum/bb-config.php:

    $bb->cookiedomain = '.sacbikekitchen.org';

    $bb->sitecookiepath = '/';

    I added the following to my /wp-config.php:

    define('COOKIE_DOMAIN', '.sacbikekitchen.org');

    define('COOKIEPATH', '/');

    Then I made a couple additions to the wp-includes/pluggable.php file:

    Around line 596 I added:

    setcookie(LOGGED_IN_COOKIE, $logged_in_cookie, $expire, '/forum/', COOKIE_DOMAIN);

    setcookie($auth_cookie_name, $auth_cookie, $expire, '/forum/bb-plugins', COOKIE_DOMAIN);

    setcookie($auth_cookie_name, $auth_cookie, $expire, '/forum/my-plugins', COOKIE_DOMAIN);

    setcookie($auth_cookie_name, $auth_cookie, $expire, '/forum/bb-admin', COOKIE_DOMAIN);

    Around line 620 I added:

    setcookie(LOGGED_IN_COOKIE, ' ', time() - 31536000, '/forum/', COOKIE_DOMAIN);

    setcookie(AUTH_COOKIE, ' ', time() - 31536000, '/forum/bb-plugins', COOKIE_DOMAIN);

    setcookie(AUTH_COOKIE, ' ', time() - 31536000, '/forum/my-plugins', COOKIE_DOMAIN);

    setcookie(AUTH_COOKIE, ' ', time() - 31536000, '/forum/bb-admin', COOKIE_DOMAIN);

    Hope it helps…


    Ed Torres
    Member

    @torresinc

    In my case I tried to install this version using my laptop, under Firefox web browser and could not login or sometimes even finish the installation due to cookies problems.

    I check Tools>Options>Privacy>Show Cookies… and my site was not there.

    I then tried to add the site manually and the problem did not solved.

    I deleted the /forum/ folder and the bb_ tables from the MySQL database and uploaded the bbForum again. This time I used my desktop and checked the cookies first. My site’s cookies were registered and the installation went smooth and the forum is operational.

    Hopefully this would help somebody.


    _ck_
    Participant

    @_ck_

    @sc0ttbeardsley, it’s really a bad idea to edit the core files – pluggable.php is specifically designed to have replaceable functions – you can take the function you edited, copy it to a new file and make it a plugin.

    Save the plugin with the appropriate header and a filename starting with an underscore and it will load instead of the function in pluggable.php

    Then when you upgrade, you won’t have to edit pluggable over and over.

    No issues so far, just wanted you to know that :) Runs fine on my (live) site!

Viewing 17 replies - 26 through 42 (of 42 total)

You must be logged in to reply to this topic.