Skip to:
Content
Pages
Categories
Search
Top
Bottom

bbp-theme-compat differences between r3981 and beta 1


  • kristarella
    Member

    @kristarella

    I was just wondering if anyone knows why the differences in bbp-theme-compat exist in the development versions and what difference is should make…

    As far as I can see the only difference is that a set of template files are duplicated in the root of that directory and the extras directory.

    I have an issue in my child theme where the visual editor (“fancy editor”) works with r3981, but not with beta 1, until I copy bbp-theme-compat from the previous version to the more recent. I’m not sure how that can be since I’m using my own template with bbp_get_template_part() for each section.

Viewing 4 replies - 1 through 4 (of 4 total)

  • John James Jacoby
    Keymaster

    @johnjamesjacoby

    Sounds like you’re only overwriting files, and not deleting the directory. Delete the entire /bbpress folder and replace it with the one from Beta 1. Should be good to go from there.


    kristarella
    Member

    @kristarella

    Mmm, you might have been right about checking out files.

    My visual editor was still broken with a brand new check out, so with the same logic in the differences I saw before, I moved all files from bbp-theme-compat/extras to bbp-theme-compat and the visual editor works.

    By not working I mean that several javascript files and one CSS file are not loaded on the page at all so the display is not quite right, the HTML/Visual links don’t do anything, the buttons do work as if it were the HTML view (quicktags.js is loaded).

    Do you have any idea why this location of files would change anything?


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    I need more specific information to be helpful. Also, the visual editor isn’t built into the template files, so they should not directly be the cause.

    I run bbPress 2.1 at testbp.org with the visual editor on; so something else must be up.


    kristarella
    Member

    @kristarella

    Ah, okay.

    I guess I was looking to see if you had an idea of where I should look next for the issue given the behaviour I’ve noticed. I don’t expect you to troubleshoot my whole system, but here it is as it stands:

    * WordPress 3.4

    * bbPress 2.1b1

    * a Thesis child theme with Thesis 1.8.5

    * a bbPress-thesis plugin I wrote to apply bbPress templates in Thesis

    (bbPress pages didn’t appear at all with Thesis until a recent change in 2.1)

    My child theme is a BuddyPress child theme for Thesis (but I don’t have BuddyPress active right now), it can be downloaded at http://www.kristarella.com/snaps/thesis-bp-child_0.3.3.zip

    The only difference between that version and the one I’m using is that I’ve added a header.php file that is the same as Thesis’ index.php (which builds the whole page, including the head). I did this because it seemed that if the active theme had no header.php the bbPress template would force a default header, and therefore default page contents too.

    The bbPress-Thesis plugin is at http://www.kristarella.com/snaps/bbpress-thesis_122.zip

    All the plugin really does is insert the template part into the middle of the page, because Thesis doesn’t use separate page templates, it has one index.php and then specifies the loop contents in a class, determining the page type from the query. So the plugin filters the loop class to add the bbPress loop content.

    All of this seems to be working fine except for the visual editor, which looks like this at first:

    http://www.kristarella.com/snaps/Thesis_visual-broken.png

    Then if I make the one change of moving the files from bbp-theme-compat/extras to bbp-theme-compat, it looks like:

    http://www.kristarella.com/snaps/Thesis_visual-working.png

    I don’t know enough about the bbPress templating to know where to look next for the fix.

    Thanks for your replies so far!

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.