Skip to:
Content
Pages
Categories
Search
Top
Bottom

bb-load, bbsync & wp_plugin_bbPress_Integration

  • Hi at all, I have some question:

    first question:

    if I put

    require_once( dirname( dirname( __FILE__ ) ) . ‘bbpress/bb-load.php’ );

    define(‘WP_BB’, true);

    on my wp_config.php, for use bbpress function on wordpress, I recive a blank page, why? is the same code that I put on bb-config.php with another path and file. (I can put wordpress function on bbpress, it works). wordpress is on the root and bbpress inside the bbpress folder.

    second question:

    i have install bbsync, on plugin page I see that there is some config to do, if I click on “It needs your config!” i’m linked on general setting, I don’t understand what I have to do for use this plugin.

    third question: is neccesary wp_plugin_bbPress_Integration?

    I put all key on bb-config and wp-config.

    thank you

    kikko088

Viewing 10 replies - 1 through 10 (of 10 total)

  • chrishajer
    Participant

    @chrishajer

    Q1 – the blank page is likely a 500 Internal Server Error. If you are not displaying errors on screen, then you will need to see the php or apache error log to find out what that is.

    here the php log

    [05-May-2010 16:55:12] PHP Warning: require_once(/Applications/MAMP/htdocs/bbpress/bb-load.php) [function.require-once]: failed to open stream: No such file or directory in /Applications/MAMP/htdocs/wp2.9/wp-config.php on line 18

    [05-May-2010 16:55:13] PHP Warning: require_once(/Applications/MAMP/htdocs/bbpress/bb-load.php) [function.require-once]: failed to open stream: No such file or directory in /Applications/MAMP/htdocs/wp2.9/wp-config.php on line 18

    [05-May-2010 16:55:44] PHP Fatal error: Cannot redeclare wp_clone() (previously declared in /Applications/MAMP/htdocs/wp2.9/bbpress/bb-includes/backpress/functions.core.php:1043) in /Applications/MAMP/htdocs/wp2.9/wp-settings.php on line 308

    [05-May-2010 16:56:13] PHP Warning: require_once(/Applications/MAMP/htdocshttp://localhost:8888/wp2.9/bbpress/bb-load.php) [function.require-once]: failed to open stream: No such file or directory in /Applications/MAMP/htdocs/wp2.9/wp-config.php on line 18

    [05-May-2010 16:56:14] PHP Warning: require_once(/Applications/MAMP/htdocshttp://localhost:8888/wp2.9/bbpress/bb-load.php) [function.require-once]: failed to open stream: No such file or directory in /Applications/MAMP/htdocs/wp2.9/wp-config.php on line 18

    I try to set another path on my wp-config.php as

    http://localhost:8888/wp2.9/bbpress/bb-load.php or

    /bbpress/bb-load.php

    but nothing

    any ideas?

    kikko088


    chrishajer
    Participant

    @chrishajer

    Whatever file you are trying to include in line 18 of wp-config.php does not exist in that location. I would make sure the path is correct and start with that one error.

    mmm, than…i work in localhost, with mamp, the folder of the sites (the mamp folder) is htdocs, my site is here:

    /application/MAMP/htdocs/wp2.9/

    while bbpress is here

    /application/MAMP/htdocs/wp2.9/bbpress

    site:

    http://localhost:8888/wp2.9/

    forum:

    http://localhost:8888/wp2.9/bbpress

    require_once( dirname( dirname( __FILE__ ) ) . ‘/bbpress/bb-load.php’ );

    define(‘WP_BB’, true);

    which is the path?

    theoretically is /bbpress/bb-load.php beacause bb-load.php in the bbpress folder inside the wp folder…right?where is the mistake?

    kikko088


    chrishajer
    Participant

    @chrishajer

    The leading slash should not be there I don’t think

    Should look like this:

    require_once( dirname( dirname( __FILE__ ) ) . 'bbpress/bb-load.php' );

    Or maybe the full path:

    require_once( '/application/MAMP/htdocs/wp2.9/bbpress/bb-load.php' );

    But the leading slash means from the root, and you don’t really mean that. /application is the root, not /bbpress.

    I try your path but nothing…:( I also try to put the code on wp-config of my site online, where the path is http://www.endurodoc.net/forum/bb-load.php but nothing… :( blank page!

    kikko088


    chrishajer
    Participant

    @chrishajer

    The path and the URL (technically URI) are not the same. To use “require_once” it needs to be a file system path. So, your “http://www.endurodoc.net/forum/bb-load.php” would never work. You need to use a file system path there (relative or absolute.)

    then, now with your path is ok!i make a mistake, the file was find but, i get this error:

    [06-May-2010 19:02:23] PHP Fatal error: Cannot redeclare wp_clone() (previously declared in /Applications/MAMP/htdocs/wp2.9/bbpress/bb-includes/backpress/functions.core.php:1043) in /Applications/MAMP/htdocs/wp2.9/wp-settings.php on line 308

    some ideas?

    tank you very much for your help :)

    kikko088


    chrishajer
    Participant

    @chrishajer

    There has always been some overlap with functions being declared in both bbPress and WordPress. I don’t know the solution to this one.

    Does the same problem happen on endurodoc.net? Installing on localhost on MAMP can be troublesome, and if you’re going to host it on the Internet anyway, it would be better to solve problems in the environment where it will ultimately reside.

    Hi, yes is the same problem happan on endurodoc, now I put all on a web site test,

    http://www.scrocco.netsons.org/wordpress/

    http://www.scrocco.netsons.org/wordpress/forum/

    0 plugin,

    [07-May-2010 17:06:04] PHP Fatal error: Cannot redeclare wp_clone() (previously declared in /home/scroccon/public_html/wordpress/forum/bb-includes/backpress/functions.core.php:1043) in /home/scroccon/public_html/wordpress/wp-settings.php on line 308

    kikko088

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.