Skip to:
Content
Pages
Categories
Search
Top
Bottom

Auto Role not working


  • husdom
    Participant

    @husdom

    Both buddypress and bbpress installed…

    Setting>Forums>Forum User Settings>Auto Role – set to participant

    Settings>buddypress>settings>Profile Settings – Enable BuddyPress to WordPress profile syncing

    After someone registers they are registered with – Site Role – subscriber and no forum role is designated.

    Mr. Fox

Viewing 8 replies - 1 through 8 (of 8 total)

  • Stephen Edgar
    Moderator

    @netweb

    What happens after you have run the repair tool “Remap existing users to default forum roles”

    http://codex.bbpress.org/repair-forums/


    husdom
    Participant

    @husdom

    Stephen Edgar,

    I just implemented the remapping as you suggested. It worked great!

    Will this remapping resolve my future registers?

    Thanks for your help.

    Mr Fox


    husdom
    Participant

    @husdom

    Another person just registered and no role was assigned for the forum.

    How can I resolve this issue so that when people sign up they are given the role of participant automatically?

    I also have buddypress on my website, could this be the root of my issue?

    Thanks again,

    Mr Fox


    husdom
    Participant

    @husdom

    Just needed to check the email notification at the bottom of the page…


    zilveer
    Participant

    @zilveer

    Hello,
    I have WP 3.7.1 installed with bbPress 2.4.1.

    When I create a user in frontend the user role is not set.

    I need to use repair forum function in order to sync every time I create a user,
    WordPress Dashboard -> ‘Tools’ -> ‘Forums’ -> ‘Repair Forums’

    I am using the default twenty eleven theme.

    Can someone please help me with this?


    zilveer
    Participant

    @zilveer

    EDIT;

    I have the following set:

    Setting>Forums>Forum User Settings>Auto Role – set to participant

    And besides my installation of WP and bbpress is new installed.

    Is this some kind of bug?

    Any help would be appreciated.


    Stephen Edgar
    Moderator

    @netweb

    Just FYI for anyone else who sees this topic:

    The forum role is not actually set until the user logs in for the first time at which time they will then be assigned the role defined in the settings.


    zilveer
    Participant

    @zilveer

    Thanks for your reply.

    When user logs in the user gets its role automatically.

    The forum role is not actually set until the user logs in for the first time at which time they will then be assigned the role defined in the settings.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.