Skip to:
Content
Pages
Categories
Search
Top
Bottom

“add new topic” broken?


  • garyditsch
    Member

    @garyditsch

    So I have intergrated bbpress into our website and it seems to be working pretty well. I used two plugins “private forums” and “approved registration”, which has also worked well.

    A couple posters pointed out to me an issue today? The “add new topic” link pulls up the form to add a topic… but when you “send post” it gives an error message:

    “This topics has been closed”

    The only way for users to add a new topic is to choose the forum they want to add it to and then scroll down and use the form on the forums page. It works and with the small number of users is ok… but hopefully the number of users grow, which it will become an issue.

    Can anyone point me in the direction of a fix?

    Here’s the link to the bbpress on our site: http://www.ditschfitness.com/forum/

    thanks

Viewing 6 replies - 1 through 6 (of 6 total)

  • chrishajer
    Participant

    @chrishajer

    Did you try it without the plugins?


    garyditsch
    Member

    @garyditsch

    Well, I did test bbpress before I used the plugins and everything appeared to work. But I’m not sure if I tested that specific function?

    Would it be a good idea to remove the plugins and retest, then set up the plugins again?

    I’m trying to decide how big an issue this is?


    chrishajer
    Participant

    @chrishajer

    It would be a good idea to remove the plugins and retest. Deciding how big an issue it is is up to you.


    garyditsch
    Member

    @garyditsch

    So I deactivated the plugins. One at a time and retested and retested with both unplugged and it still wouldn’t post a new topic from the “home” page of the forum.

    This still only appears to be an issue of posting from the home page? Is it possible that the “add new topic” link on the home page is tied to a forum that doesn’t exist anymore?

    How does bbpress decide which forum to put a new topic into when it is started from the home page? Does it give you a drop down box to pick the forum?

    thanks.


    Sam Bauers
    Participant

    @sambauers

    This is a problem with parse_url() dying when there is an http:// in the querystring. The latest commit in branches/0.9 fixes this problem, which would only occur when trying to add a new topic when not logged in.


    Amir Habibi
    Member

    @amirhabibi

    Hi sambauers,

    Is there a specific file to change or i have to get the hole commit ?

    For info, the bug is visible in this forum !

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.