Skip to:
Content
Pages
Categories
Search
Top
Bottom

500 error when searching

Viewing 8 replies - 1 through 8 (of 8 total)

  • kai920
    Member

    @kai920

    I tried the search on localhost and I got a bunch of these in my apache error log:

    [Thu Aug 12 20:46:05 2010] [notice] child pid 27639 exit signal Segmentation fault (11)

    [Thu Aug 12 20:46:19 2010] [notice] child pid 27640 exit signal Segmentation fault (11)

    [Thu Aug 12 20:47:01 2010] [notice] child pid 30872 exit signal Segmentation fault (11)

    [Thu Aug 12 20:47:06 2010] [notice] child pid 27378 exit signal Segmentation fault (11)

    [Thu Aug 12 20:47:12 2010] [notice] child pid 30894 exit signal Segmentation fault (11)

    [Thu Aug 12 20:47:50 2010] [notice] child pid 30895 exit signal Segmentation fault (11)

    I am using MAMP as my localhost dev server.


    chrishajer
    Participant

    @chrishajer

    What plugins are you using, and what version of bbPress, PHP and MySQL?


    kai920
    Member

    @kai920

    bbPress 1.0.2

    PHP 5.2.13

    MySQL 5.1.47-community-log

    As for plugins, these are installed and activated:

    Allow images

    BBcode buttons toolbar

    BBcode Lite

    bbPress Smilies

    Check for Updates

    Hidden Forums

    Hot Tags Plus

    Nicer Permalinks

    Related Topics

    Support forum

    Unread Posts


    chrishajer
    Participant

    @chrishajer

    That segfault error looks like Apache is actually dying. That’s pretty odd. Are there any other errors being logged? This segmentation fault is not the 500 error. That should be logged separately.

    All your versions look fine.

    Are you using a custom template?


    kai920
    Member

    @kai920

    I am using the default theme Kakumei (sp?). I don’t see any other errors of note in my MAMP log, and the Bluehost error log I don’t see anything useful either…

    You know what, I disabled nicer permalinks (on localhost) and it seems to work now, so this plugin may be the culprit.

    Could it be a conflict because my bb-press is installed in /forum?

    Here is what my .htaccess looks like when Nicer Permalinks is enabled:

    # BEGIN bbPress

    Options -MultiViews

    <IfModule mod_rewrite.c>
    RewriteEngine On

    # /forum/ and bb_get_option( 'path' ) must match
    RewriteBase /forum/

    Options +FollowSymlinks

    # admin stuff, not processed
    RewriteRule ^bb-admin/.*$ - [L,QSA]

    RewriteRule ^page/([0-9]+)/?$ ?page=$1 [L,QSA]

    RewriteRule ^profile/([^/]+)/([^/]+)/page/([0-9]+)/?$ profile.php?id=$1&tab=$2&page=$3 [L,QSA]
    RewriteRule ^profile/([^/]+)/page/([0-9]+)/?$ profile.php?id=$1&page=$2 [L,QSA]
    RewriteRule ^profile/([^/]+)/([^/]+)$ profile.php?id=$1&tab=$2 [L,QSA]
    RewriteRule ^profile/([^/]+)$ profile.php?id=$1 [L,QSA]
    RewriteRule ^profile/$ profile.php [L,QSA]

    RewriteRule ^rss/forum/([^/]+)/topics/?$ rss.php?forum=$1&topics=1 [L,QSA]
    RewriteRule ^rss/forum/([^/]+)/?$ rss.php?forum=$1 [L,QSA]
    RewriteRule ^rss/profile/([^/]+)$ rss.php?profile=$1 [L,QSA]
    RewriteRule ^rss/tags/([^/]+)/topics/?$ rss.php?tag=$1&topics=1 [L,QSA]
    RewriteRule ^rss/tags/([^/]+)$ rss.php?tag=$1 [L,QSA]
    RewriteRule ^rss/topic/([^/]+)$ rss.php?topic=$1 [L,QSA]
    RewriteRule ^rss/view/([^/]+)$ rss.php?view=$1 [L,QSA]
    RewriteRule ^rss/topics/?$ rss.php?topics=1 [L,QSA]
    RewriteRule ^rss/?$ rss.php [L,QSA]

    RewriteRule ^tags/([^/]+)/page/([0-9]+)/?$ tags.php?tag=$1&page=$2 [L,QSA]
    RewriteRule ^tags/([^/]+)$ tags.php?tag=$1 [L,QSA]
    RewriteRule ^tags/?$ tags.php [L,QSA]

    RewriteRule ^view/([^/]+)/page/([0-9]+)/?$ view.php?view=$1&page=$2 [L,QSA]
    RewriteRule ^view/([^/]+)$ view.php?view=$1 [L,QSA]

    # forums
    RewriteRule ^([^/]+)/page/([0-9]+)/?$ forum.php?id=$1&page=$2 [L,QSA]
    RewriteRule ^([^/]+)/$ forum.php?id=$1 [L,QSA] # tailed '/' is mandatory for forum URIs! Props: Mohta

    # topics
    RewriteRule ^([^/]+)/([^/]+)/page/([0-9]+)/?$ topic.php?id=$2&page=$3 [L,QSA]
    RewriteRule ^([^/]+)/([^/]+)$ topic.php?id=$2 [L,QSA]

    # other pages
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^.*$ index.php [L]
    </IfModule>

    # END bbPress


    kai920
    Member

    @kai920

    it appears disabling Nicer Permalinks on the Bluehost site also got rid of the 500 error.


    kai920
    Member

    @kai920

    OK, it most certainly seems Nicer Permalinks is causing issues with my search but why? I tried moving bbpress to /forums instead of /forum and the same 500 error occurs when searching.

    I think there must be happy users of Nicer Permalinks whose search functions properly…?


    chrishajer
    Participant

    @chrishajer

    If you have access to more error logs you should be able to see what’s happening. If not, you will need to enable custom error logging and then enable the plugin to see what the error is when you search.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.