Skip to:
Content
Pages
Categories
Search
Top
Bottom

404 headers when using blog-header.php


  • Ryan
    Participant

    @ryannutt

    I’m calling the blog-header.php file from WordPress, which from what I’ve read is part of the problem. I’m doing so because I’m using the same sidebars, header, and footer in my forum as the blog. If there’s another, relatively easy, way to do that then I’m all ears.

    When using permalinks for the bbPress pages a 404 header is being returned. The page displays ok in Firefox & IE7, but the 404 is going to cause issues with search engines.

    Any suggestions on how to fix the problem?

Viewing 3 replies - 1 through 3 (of 3 total)

  • chrishajer
    Participant

    @chrishajer

    WordPress is thinking this forum page does not exist., so WordPress throws the 404 but the page is still properly served. It happens only because you’ve included blog-header.php (a normal integrated installation wouldn’t do this).

    I think this post covers it (basically, install a WordPress plugin to overcome the problem):

    http://bbpress.org/forums/topic/bbpress-wordpress-mu-or-not-leads-to-404-errors-but-pages-still-load#post-13156


    Ryan
    Participant

    @ryannutt

    I looked at doing that, but won’t it cause any non-existing page to show a 200 header as well?


    Ryan
    Participant

    @ryannutt

    Ok, that wasn’t the plugin I thought it was. That one worked pretty well, minus a couple of glitches. It was still sending a 404 header for profile and tags pages so I added /forum/profile and /forum/tags to the rewrite rules and now they all return 200 headers.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.