Skip to:
Content
Pages
Categories
Search
Top
Bottom

2.2.3 – Fatal error: Unknown: Cannot use output buffering


  • allenmccabe
    Participant

    @allenmccabe

    I have s2Member running with bbPress 2.2.3 and I am getting the following error when accessing the Users page within the admin:
    `Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0`

    Version 2.2.2 does not do this on the development server (also running with s2Member).
    Wordpress version 3.4

Viewing 5 replies - 1 through 5 (of 5 total)
  • bbPress 2.2.3 was released 11 December 2012

    S2Member developer @WebSharks posted details of S2Member fixes in the following thread ~22 December 2012 http://bbpress.org/forums/topic/fix-for-users-of-s2member-and-bbpress-2-2/

    I am ‘presuming’ S2Member/@WebSharks was testing against bbPress 2.2.3

    This is the first time I have seen anyone mention the error you detail above.

    Have you any other plugins recently updated that maybe the cause of this?

    Have you tried any extra combinations of the plugins eg. bbPress 2.2.2 & S2Member v121213 to see if it is an S2Member issue rather than bbPress?

    ps. I also see your thread on S2Members forum with no answers at the time I wrote this http://www.s2member.com/forums/topic/bbpress-2-2-3-fatal-error-on-users-page/


    allenmccabe
    Participant

    @allenmccabe

    This plugin was a fresh install on the Production server; the Development server has almost identical configuration. Upgrading Development plugin of bbPress to 2.2.3 does NOT reproduce this error.

    - ‘production’ server: WP 3.4, S2Member v??? & bbPress 2.2.3 <- Produces the error in your OP
    – 'development' server: WP 3.4, S2Member v??? bbPress 2.2.2 and/or 2.2.3 <- Does not produce the error

    So what are the differences between your 'almost identical configuration'?


    allenmccabe
    Participant

    @allenmccabe

    - ‘production’ server: WP 3.4, S2Member Pro v120703 & bbPress 2.2.3 <- output buffering error on Users page
    – 'development' server: WP 3.4, S2Member Pro v120703 bbPress 2.2.2 and/or 2.2.3 <- no error

    List of plugin differences between servers:
    Plugin Prod Dev
    Advanced Custom Fields 3.1.6 3.5.0
    Affiliates —– 2.1.5
    Affiliates Pro 2.2.1 —–
    Affiliates Pro s2Member Integration 2.0.1 —–
    Affiliates WP e-Commerce Integration 1.0.1 —–
    CloudFlare 1.3.5 —–
    WordPress HTTPS 2.0.4 3.2

    So what happens if you disable those plugins? Does the problem still exist?

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.