Skip to:
Content
Pages
Categories
Search
Top
Bottom

1.0 alpha 2: permalink none cannot be set back

  • Hi,

    related indirectly to the post: http://bbpress.org/forums/topic/10-alpha-2-parse-url-error

    I thought it may be something to do with the permalinks settings so I tried to revert back to “None..” in ADMIN > SETTINGS > GENERAL, but I cannot seem to change back from “Name based” to “None”; it just goes back ot “Name based” when you click “Save changes”, but I can set it to “Numeric”

    I thought you might be doing something clever like checking for ther .htaccess file that needs to be uploaded to get the numeric and name based links to work, so I deleted the .htaccess file but still no luck.

    Any suggestions would be appreciated.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hey,

    Have you made sure your .htaccess file is CHMOD to writable?

    E.g permission 777?

    Just tried CHMODing the htaccess file to 777 and then trying to change back to NONE permalinks – still not going back.

    Thanks for the suggestion though!

    I think on the admin panel (bbPress) there’s a link in the description of the permalinks settings part, that when you click it will display the .htaccess code thats meant to be in your .htaccess.

    Now I don’t quite know why your having problems but I have also come across problems with something called multi views.

    Sometimes permalinks won’t work because of multiviews not being ables. Try adding this to the very top of your .htaccess:

    Options +MultiViews

    Hi,

    I already had the “Options -MultiViews” at the top and simply changed the – to + but that did not help to get the permalink setting back to none.

    Do you know if your web-host supports multi views? Might be a idea to ask them. Although I am new to bbPress myself there might be something else causing problems. But from reading various topics permalink problems seems to be connected to the .htaccess.

    I can’t really offer anymore help but im sure a moderator or other member will post help. When they see you topic.

    Thanks for your help anyway Epiphone, it’s much appreciated.

    Let’s see what the bbPress team come back with.

    Thank you again :)

    I think that’s just a glitch in the code because the permalinks remain in the “None” type (when saved as such) even so the dropdown in the general section of the admin menu will switch back to “Name based”.

    For now, just make sure to reselect “None” when saving any other changes to General Settings I guess.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.