Out today is bbPress 2.5.3, a bug fix release that also comes with improved support for WordPress 3.8′s new, more modern administration area design. A few of the more notable changes are outlined below:

  • WordPress 3.8 support (dashicons, new color schemes)
  • Fix dropdown selects in settings pages
  • Fix accidental topic subscription removal on reply form
  • Fix poor grammar in profile title element
  • Fix admin area SSL support

Check out the changelog on trac for a complete list of tickets and changes.

Discuss bbPress 2.5.3

Viewing 25 replies - 1 through 25 (of 43 total)

  • mariz_p
    Participant

    @mariz_p

    the admin icons for forums, topics and replies are missing. May you please check it? I’m using the latest wordpress.


    Nashwan Doaqan
    Participant

    @alex-ye

    Congratulations! .. nice to see the bbPress Trac new updates too :D

    the admin icons for forums, topics and replies are missing. May you please check it? I’m using the latest wordpress.

    Try clearing your browser cache/history or hard refresh


    mariz_p
    Participant

    @mariz_p

    that worked Stephen… Thanks.


    trickedoutrick
    Participant

    @trickedoutrick

    The “Forum” link on my admin sidebar (back end) is gone? I also can’t find any settings for bbPress anymore, did it move/get integrated with Buddy Press? I can’t find it -.-


    hulajoe
    Participant

    @hulajoe

    I am having the same problem with bbPress when AWPCP is installed alongside it … There is a conflict somewhere with bbPress 2.5.3 and AWPCP 3.0.1 running on WP3.8 … These are all the latest versions, so PLEASE help me to find the fix. AWPCP and bbPress are both core components of my site and I need them to play nicely (like they used to)

    Thanks – Joe


    Stephen Edgar
    Moderator

    @netweb

    @hulajoe I posted a link to supposed update here. (You have to contact them to get the update, it’s not available publicly)


    merosler
    Participant

    @merosler

    Hi guys,

    I found your thread and was wondering if anyone out there was having a problem with buddypress registration issues.

    Problem:
    bbPress (2.5.3) seems to completely ignore what the user had originally set as their password on my registration page from the very beginning of registration.

    More detailed explanation:
    On the registration page, the user chooses their own password, and then once I approve the user, the user is then sent an automated registration message which then assigns the user a new random password. The user then has to log in using this random password and reset the password.

    Have you encountered this? Any solutions?

    thank you,
    Matt


    helmutwalker
    Participant

    @helmutwalker

    I just installed the latest version and it is running super sloooow. I’ve checked and it is not a theme issue.


    John James Jacoby
    Keymaster

    @johnjamesjacoby

    How did you check? How do you know? What exactly is slow?


    helmutwalker
    Participant

    @helmutwalker

    My apologies, I think this is a server issue. I did switch themes and when I deactivated bbpress it was running smoothly but it seems to be ok now.


    brightbell
    Participant

    @brightbell

    I have recently lost access to most of bbPress.
    There is no backend access at all, even the link to settings in the plugin list is not present
    and nothing at all down the LHS however the forum listing does appear on the front end if no user is logged in.
    Also some shortcode widget items appear on the front page in the footer.
    When anyone logs even the keymaster the forum is less visible.
    I had to recreate the keymaster which dissapeared and became a moderator.
    The keymaster was no longer listed as an option to reselect so I had to
    change the role thus in this line with phpmyadmin

    a:3:{s:13:”administrator”;b:1;s:20:”add_ultimate_auction”;b:1;s:13:”bbp_keymaster”;b:1;}

    I am not sure whether this occurred exactly as 2.5.3 was installed but it became evident soon after.

    WordPress 3.8.1 running Hueman theme.


    lanse20
    Participant

    @lanse20

    Hello admin.

    I m from china and my english is not good, so please forgive me for my words
    I dont know if this question is mentioned before
    I run a simple website ,
    evilstore.me for my group of people
    and bbpress is a very important part.we chat and discuss with it a lot.
    I have a problem.in the “Activity” , Comments and replies have no notifications ,this make me really hard to see whats happening,I hope the next buddypress can have a notification for Comment reply notifications. that would really helpful
    please tell me how can i solve this problem ,or if there is any similar cases,thank you so much


    mariz_p
    Participant

    @mariz_p

    Hello Stephen and John,

    I just noticed an error in the User Profile.
    When the user edit his password to 2 characters long, it still saves.
    Where it must have an at least 10 characters long.
    May you please check it?

    Your password should be at least ten characters long. Use upper and lower case letters, numbers, and symbols to make it even stronger.

    Thanks.

    @@mariz_p This is not a ‘standard feature’ of WordPress or bbPress, I presume you are using a plugin to enable this. What plugin is it?

    Depending upon how the plugin implements this it ‘might’ be something bbPress could add support for in the bbPress login widget and form-user-*.php templates, but most likely this we be difficult to do for compatibility of ‘all the plugins’ that enable this feature.

    Most likely you will need to customize the form-user-*.php templates to match the plugin you are using.


    mariz_p
    Participant

    @mariz_p

    no, it’s not a plugin feature. It’s actually a wordpress issue. I just found it today when I tried changing my password to 2 characters long. I’ll report this bug to them. Thanks Stephen.


    timi23
    Participant

    @timi23

    i just created the bbpress forum on my site, but is not showing on the site. how dow i solve this?


    eefadmin
    Participant

    @eefadmin

    Hi, the function “Enable threaded (nested) replies” is suddenly to be ineffective on my site when I edited a reply: it’s now shown as flat format, regardless of what number of the level deep set.


    napalees
    Participant

    @napalees

    Hi, I’ve updated to newest version recently. And I’m experiencing a serious bug… If I remember correctly. I installed BBpress some time arround november. It workewd OK for me. Now when new user registers with me he does not get forum role automatically. I must assign it manualy. In forum settings Automatically give registered visitors the Participant forum role is checked.
    I’d appreciate your help on this problem or link to the older version whitch was official around the end of november

    TIA


    napalees
    Participant

    @napalees

    Please ignore my post above. It adds the role on first log in after all…
    Cheers! ;)


    kwellafrica
    Participant

    @kwellafrica

    Hi,
    I currently have bbpress 2.5.3 installed on WP 3.8.1 and my biggest problem is that I don’t have the FORUM tab on my dashboard after fresh installation? I can’t find any settings for bbPress as well!! I’ve refreshed my browsers and empty all the catches, but no luck! Please help, big thanks for your soonest reply.


    mariz_p
    Participant

    @mariz_p

    hi @kwellafrica.. just add forum on your sitelink.. Like this: http://example.com/forum.
    Then your problem is solve.


    kwellafrica
    Participant

    @kwellafrica

    Hi @mariz_p
    Thanks for your help, but I am still quite new with all these set up,I am not too sure where I can add the link to my site somewhere from backend dashboard or from adding a new page on dashboard? Thank you again


    kwellafrica
    Participant

    @kwellafrica

    Hi @mariz_p
    I got it working now, big thanks!!!:)


    OC2PS
    Participant

    @sooskriszta

    I just posted a topic with title “Last post date-time instead of Freshness” in bbpress.org support forums. It doesn’t appear anywhere. But when I tried again, I got a “duplicate” message. Please can you check and advise?

Viewing 25 replies - 1 through 25 (of 43 total)

You must be logged in to reply to this topic.